Game stuck

Home Forums Support Game stuck

This topic contains 5 replies, has 4 voices, and was last updated by  MasterNightmare 7 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
Author Posts
Author Posts
March 21, 2017 at 2:04 pm #225

Sassy

Stuck on skeleton restored screen at healing hut. Has been like this for 4 days now. When I use home option, I get skeleton restored screen. When I choose return to Fair Oaks, skeleton restored screen. Every option is the same result. I sent an email with screenshots to lotb@nostalogic.com but it gets returned, address not found.

Can anyone help me please?

April 5, 2017 at 10:37 pm #231

Scorpio

Make sure your remember your password and try uninstalling the app and installing it again and then logging in again? Maybe it will start you on a new day?

April 6, 2017 at 2:22 am #234

bareil

The email you posted is missing a ‘d’.

lotbd@nostalogic.com

April 7, 2017 at 8:20 am #235

Scorpio

Barrel, that email and the website, even spelled correctly appears to be down, FYI.

April 7, 2017 at 8:21 am #236

Scorpio

*Bareil. Sorry autocorrect.

October 9, 2017 at 2:53 pm #242

MasterNightmare

Hey I’m currently stuck in the mercenary camp and can’t get out. I tried the uninstall that you mentioned to sassy but it didn’t work for me I’m still stuck.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

© 2018 Nostalogic. All Rights Reserved. Blue Dragon by Christopher Taylor.